将脚本从 AX 迁移到 机器人
对于打算在 机器人 中重新创建的每个 AX 自动化流程,您都需要迁移关联的脚本。您需要迁移所有分析脚本以及任何子脚本或者帮助类脚本。
您无法将脚本直接从 AX 迁移到 机器人。您需要将脚本从 AX 导出到安装了 Analytics 的中间位置(例如您自己的计算机)。在完成任何必要的准备工作后,将脚本从中间位置提交(上传)到 机器人。
机器人 的向后兼容性
一般而言,机器人 被设计为尽可能地与 AX 保持向后兼容。大多数 AX 脚本应无需任何修改即可在 机器人 中运行。
任何依赖于 AX 特定设计的脚本都将需要进行调整。例如:
- 访问 AX 操作数据库以读取作业计划或日志的脚本
- 包含在 机器人代理 服务器上不再有效的服务器资源绝对路径的脚本
如果您在调整分析脚本以便在 机器人 中使用时需要帮助,请联系 Diligent 支持。
从 AX 导出脚本
要开始迁移,请使用导出选项从 AX 导出脚本。脚本是在包含它们的分析应用程序中导出的。每个导出的分析应用程序都会在导出目标位置成为一个单独的 Analytics 项目。
此过程假定您使用自己的计算机作为中间位置。
- 在您的计算机上创建一个用于存储导出脚本的文件夹。
- 在 AX 服务器资源管理器中,选择包含您想要导出的脚本的分析应用程序。
您可以按住 Ctrl 键并单击以在同一个分析应用程序父文件夹中选择多个分析应用程序,或者选择该父文件夹以导出该文件夹中的所有分析应用程序。
- 选择文件 > 导出。
- 在导出对话框中,确保两个选项都未选定:
- 使用导出的文件?
- 将数据文件与选定的定义一起导出
- 单击浏览,选择您为存储脚本而创建的文件夹,然后单击确定。
- 单击确定以导出一个或多个分析应用程序。
这些脚本被从其分析应用程序中导出到指定的位置。每个分析应用程序都会被转换为一个 Analytics 项目。
- 对于您准备好迁移的任何附加脚本,重复执行该流程。
链接的分析脚本
与 AX 不同,机器人 不支持链接的分析脚本。如果您在 AX 中使用链接的分析脚本,请导出主分析脚本,然后将其提交至每个需要它的机器人。
完成任何必要的准备工作
从 AX 导出后,如果满足以下条件,脚本即可提交到 机器人:
- 所有与自动化流程关联的脚本都位于单个 Analytics 项目中
- 所有必须在自动化流程中按顺序执行的分析脚本:
- 使用适当的字母数字命名方案
- 如果被实现,则具有适当的分析类型
分析链
与 AX 不同,机器人 不支持分析链。如果您使用分析链,在脚本准备好提交到 机器人 之前,您可能需要进行一些准备工作。有关详细信息,请参阅 。
将脚本提交(上传)到 机器人
一旦与某个自动化流程关联的所有脚本都包含在单个 Analytics 项目中且命名正确,您就可以将脚本提交到 机器人。
提交脚本时,可将其从本地环境上传至基于云的机器人应用程序。我们使用单词“提交”而不是“上传”是因为,每当您将脚本提交至同一个机器人,您都是在脚本历史记录中创建这些脚本的一个新版本。
有关详细信息,请参阅将 ACL 脚本提交(上传)到 机器人。
- 打开包含您要提交的脚本的 Analytics 项目。
- 从 Analytics 主菜单中选择文件 > 提交脚本。
如果出现错误消息,则在该项目中的一个或多个脚本的解析标头或脚本语法中可能存在问题。
有关详细信息,请参阅 Analytics 和 机器人 中的 ACL 脚本开发工作流程。
- 如果需要,请在选择目标对话框中双击适当的 Diligent One 实例。
将会显示机器人集合,其中包含现有机器人的列表。
- 在机器人列表中,选择要提交脚本的机器人,然后单击确定。
包含这些脚本的 Analytics 项目和现有机器人现在会被关联,以便后续的提交不需要您手动定位机器人。
输入一个简短的提交消息以描述所提交的脚本,然后单击确定。
脚本被提交至机器人中的开发模式。
- 在提交脚本成功对话框中,单击第二个链接以检查 机器人 应用程序中刚提交的脚本。
脚本版本选项卡打开,其中包含这些脚本的已提交版本。
- 选择脚本版本 (vn)。
版本详情侧面板打开。各个分析脚本和辅助脚本的名称被列在脚本版本更改下。
- 在 Analytics 中,单击确定退出提交脚本成功对话框。
在 机器人 中复制分析链
说明
本节仅适用于您在 AX 中使用分析链的情况。
与 AX 不同,机器人 目前不支持将来自存储库中的任意位置的分析脚本组装为按顺序执行的分析链。要在 机器人 中实现一系列分析脚本的顺序执行,您需要做两件事:
- 在单个机器人中包含这些分析脚本,然后创建单个任务以执行这些脚本
- 使用脚本名称和分析类型创建一个脚本序列
将这些分析脚本包含在单个机器人中
将您想要按顺序执行的分析脚本包含在单个机器人中。
要在单个机器人中包含这些脚本,需要先将所有相关脚本包含在单个 Analytics 项目中。您将这些脚本作为名为脚本版本的单个包从 Analytics 项目提交到机器人。
一旦这些脚本位于单个机器人中,您就可以创建单个任务来执行该系列分析脚本。
在单个 Analytics 项目中包含关联脚本
如果与单个自动化流程关联的脚本分布在两个或多个 Analytics 项目中,您必须先将脚本统一到单个项目中,然后再将其提交到 机器人。如果分析脚本是 AX 中的分析链一部分,则可能出现此情况。
- 打开您要用于包含与自动化流程关联的所有脚本的 Analytics 项目。
- 在导航器的概览选项卡上,右键单击树视图顶部的项目名称,然后选择从另一项目复制 > 脚本。
- 在查找项目文件对话框中,找到并选择要从中复制脚本的 Analytics 项目,然后单击打开。
- 在导入对话框中,完成下列任一步骤以便将一个或多个脚本添加到到项目名称列表中:
- 双击某个脚本。
- 按住 Ctrl 键并单击多个脚本,然后单击右箭头按钮。
- 单击全部添加以添加所有脚本。
- 单击确定将脚本复制到目标项目中。
如果该项目中已存在具有相同名称的脚本,则复制的脚本会被赋予一个递增的数值后缀。
- 对于其他项目中任何需要被包括在目标项目中的脚本,重复执行该流程。
使用脚本名称和分析类型创建一个脚本序列
脚本名称
分析脚本被在机器人任务中按名称的字母数字顺序排序,并且按顺序执行,因此,请按照能够创建您希望的执行顺序的方式命名分析脚本。
例如,该序列中的第一个脚本可以使用前缀 A_01,第二个脚本可以使用 A_02 或者 B_01,依此类推。前缀系统使得后续插入附加的脚本变得更容易。子脚本或者帮助类脚本不受顺序命名要求的限制。
说明
您无法在 机器人 中重命名脚本,因此在将其提交到 机器人 之前,请确保所有脚本已在 Analytics 中正确命名。
分析类型
作为一种附加的排序辅助手段,您可以选择为分析脚本指定一个类型。指定类型可以将脚本分组到任务中的不同区域。区域被按如下方式排序,并且按顺序执行:
- 导入
- 准备
- 分析
在每个区域内,脚本被按字母数字顺序排序。无论脚本名称是什么,一个任务都会在转至下一个区域之前执行某个区域中的所有脚本。
有关详细信息,请参阅 ANALYTIC 标签。
重命名分析脚本以创建一个执行顺序
如果您想要让两个或更多个分析脚本按顺序执行,则需要按照能够创建您希望的执行顺序的方式命名它们。有关详细信息,请参阅 。
说明
分析标头中指定的分析脚本名称是在 机器人 中使用的名称。导航器的视图选项卡中的脚本名称未使用。
- 在 Analytics 中,打开要重命名的分析脚本。
- 在分析标头中的 //ANALYTIC 标签中,更新分析名称,然后单击保存打开的项目
。有关详细信息,请参阅 ANALYTIC 标签。
- 对于所有需要重命名的分析脚本,重复执行该流程。
指定一个分析类型来分组分析脚本
如果您想要将分析脚本分组到任务的单独导入、准备和分析区域中,您需要为每个脚本指定相应的分析类型。对分析脚本进行分组为您提供一个用于创建脚本序列的附加选项,但它不是必需的。有关详细信息,请参阅 。
- 在 Analytics 中,打开要为其指定类型的分析脚本。
- 在分析标头中的 //ANALYTIC 标签中,添加一个分析类型,然后单击保存打开的项目
。有关详细信息,请参阅 ANALYTIC 标签。
- 对于所有需要分析类型的分析脚本,重复执行该流程。
下一步
一旦您已迁移一个或多个自动化流程的脚本,您就可以开始迁移数据了:将数据从 AX 迁移到 机器人。
